PHP, which is a backronym for PHP: Hypertext Preprocessor, is one of the most popular dynamic programming languages available out there. Any site or web application built on PHP will run on a given server provided that a PHP module is installed, which makes the language absolutely universal and it’s not very surprising that there are a few million web servers that support it and 100s of millions of PHP sites hosted on them. PHP is preferred over HTML because it allows you to create a responsive website with tons of options. A PHP-based social networking site, for example, will serve different content to each visitor even though the page URL will stay the same. By contrast, HTML-based sites are static and the page content can be modified only manually. Like any other software, PHP has different versions and the version that was used whilst building a certain website must be activated on the server so that the site can run flawlessly.

PHP 4 and PHP 5 Support in Shared Hosting

We’ve made a conscious decision not to prevent our present and prospective customers from picking what PHP version their sites will use, so in case you buy a shared hosting plan from our company, you’ll be able to choose between versions 4, 5.2, 5.3, 5.4 and 5.5, not only for the hosting account in general, but also for each single domain that you host. This can be done with just one single mouse click through our custom-built Hepsia Control Panel via which all shared web hosting accounts are administered, so you will not have to possess any programming or technical expertise. You will be able to run websites built with both new and old PHP-based scripts without having to overcome any obstructions, so if you want to change your current hosting provider and switch over to us, you can be sure that all the websites that you have built throughout the years will continue to run properly.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Even if your websites were created with an older PHP version, you’ll be able to host them in a semi-dedicated server account from us, as we support several versions running at the same time on our servers and each one of them can be activated for your account with just a click via our custom Hepsia hosting Control Panel. Other than the newest PHP 5.4 and PHP 5.5, we also support 5.2, 5.3 and the older PHP 4. The latter has already been abandoned by the vast majority of hosting companies, but we consider that you shouldn’t be forced to modify a site that took years to build, since older scripting language syntax doesn’t automatically suggest security loopholes. On the contrary, an adequately maintained site using PHP 4 can be more reliable than a poorly maintained one using PHP 5. For the sake of your convenience, we will also give you the opportunity to choose a different version for each individual site within your account.